Au secours! Multiswitch et SBEC

Page 6 sur 6 Précédent  1, 2, 3, 4, 5, 6

Voir le sujet précédent Voir le sujet suivant Aller en bas

Re: Au secours! Multiswitch et SBEC

Message par rookie78 le Sam 6 Déc 2014 - 12:03

fabco a écrit:
Il me semble que ces différents essais se sont fait avec le moteur non alimenté.
Que ce passe-t-il si celui-ci est alimenté et chargé si possible. ?

Aussitôt demandé, aussitôt fait...
Réponse: Il ne se passe rien.
Montage: Filtre complet en place (Capas + Diode).
Moteurs alimentés, Multiswitch s'initialise et fonctionne parfaitement tant que je n'active pas un servo comme décrit précédemment.
Donc avec le Multiswitch initialisé, je lance les moteurs. Multiswitch fonctionne, pas d'activation de canal ou d'interruption de l'initialisation. Je les charge en freinant les cages avec la pression d'un bout de balsa. Il ne passe rien, le Multiswitch continu de fonctionner nickel.
Seule l'activation d'un servo perturbe un poil le Multiswitch.

Marcel.
-----------------

avatar
rookie78

Age : 69

http://www.tournereau.com/modelisme/Accueil/Accueil.html

Revenir en haut Aller en bas

Re: Au secours! Multiswitch et SBEC

Message par GAZOU le Sam 6 Déc 2014 - 12:11

Bonjour

encore une idée en passant d'un nul en électronique

c'est pareil avec des servos numériques qu'avec des servos analogiques ?

_________________
Etre à plat ventre c'est bien !  Mais c'est une position inconfortable pour lécher la main de celui qui vous botte le cul
et ça que j'aime bien
Quand j'entend un con discourir sur un forum je suis affligé , mais je me console en me disant qu'il pourrait être sur le Bleu
avatar
GAZOU
Admin

Age : 74

Revenir en haut Aller en bas

Re: Au secours! Multiswitch et SBEC

Message par Lagaffe le Sam 6 Déc 2014 - 13:03

Un problème d''alimentation ne m'étonnerait pas, en plus du reste.
Et ce n'est pas un condensateur qui va éliminer la chute de tension provoquée par le démarrage d'un servo (avec un courant de plusieurs Ampères)
avatar
Lagaffe

Age : 70

Revenir en haut Aller en bas

Re: Au secours! Multiswitch et SBEC

Message par jolibob le Sam 6 Déc 2014 - 13:43

Bonjour Rookie78,

Question anodine : qu'elle est la marque de ton SBEC (ou de ton contrôleur avec SBEC) ?

Cordialement
avatar
jolibob

Age : 67

Revenir en haut Aller en bas

Re: Au secours! Multiswitch et SBEC

Message par rookie78 le Sam 6 Déc 2014 - 14:20

jolibob a écrit:Bonjour Rookie78,

Question anodine : qu'elle est la marque de ton SBEC (ou de ton contrôleur avec SBEC) ?

Cordialement

Contrôleur Pro-Tronik ESC BFu 95A U-Bec 4A - Black Fet series

http://www.a2pro-online.com/esc-bfu-95a-u-bec-4a-black-fet-series.html

Notice: http://www.a2pro-online.com/media/manuals/electronics/78006to78120-ESC-BLACKFET.pdf

Marcel.
avatar
rookie78

Age : 69

http://www.tournereau.com/modelisme/Accueil/Accueil.html

Revenir en haut Aller en bas

Re: Au secours! Multiswitch et SBEC

Message par rookie78 le Sam 6 Déc 2014 - 14:23

Lagaffe a écrit:Un problème d''alimentation ne m'étonnerait pas, en plus du reste.
Et ce n'est pas un condensateur qui va éliminer la chute de tension provoquée par le démarrage d'un servo (avec un courant de plusieurs Ampères)

Mouais... Sauf que si je monte un Rx en 42Mhz et alimente le tout avec le SBEC tout marche nickel et je peux activer autant de servos que je veux sans avoir d'interférences... Vicieux je vous dis...

Marcel.
----------------
avatar
rookie78

Age : 69

http://www.tournereau.com/modelisme/Accueil/Accueil.html

Revenir en haut Aller en bas

Re: Au secours! Multiswitch et SBEC

Message par fabco le Sam 6 Déc 2014 - 15:50

intéressante la doc du controleur.
Il y a pas mal de recommandations
comme celle-ci
Votre U-BEC PROTRONIK est conçu pour faire face aux appels de courants que génèrent les servos durant un vol. Ainsi, un
bref appel de courant dépassant de 20 % la valeur nominale ne déclenche pas le système IFR

Votre U-BEC PROTRONIK repose sur le principe du découpage à haute fréquence. Bien que toutes les précautions soient
prises afin que ce module rayonne le plus faiblement possible, nous vous conseillons de placer votre U-BEC le plus loin possible du
récepteur et de son antenne. Nous vous rappelons qu’un test de portée doit être réalisé de façon impérative et systématique avant chaque vol.

des fils sont même torsadés en guise de blindage

il a l'air d'être sensible ce petit bijou de technologie
avatar
fabco

Age : 63

Revenir en haut Aller en bas

Re: Au secours! Multiswitch et SBEC

Message par rookie78 le Sam 6 Déc 2014 - 15:58

Quelques tests supplémentaires pour documenter l'histoire du voltage lors d'un appel de courant par un servo:
- Les servos sont des analogiques Pro-Tronik 6811-MG-A, 11kg/cm sous 4,8v, 13kg/cm sous 6v.
- Montage avec Rx 42Mhz le tout alimenté par SBEC: J'active 2 ou 3canaux du Multi-Switch pour avoir les LEDs témoins allumées. J'actionne un servo. L' intensité lumineuse des Leds fluctuent trés légèrement mais sans perturbation de l'état du Multiswitch. On voit quand même une légère influence de l'appel de courant du gros servo.
- Montage avec Rx 42Mhz le tout alimenté par Accus: Même chose. Là aussi légère fluctuation mais sans perturbation.
- Montage avec Rx 2,4Ghz le tout alimenté par Accus. Même chose que précédemment avec trés légère fluctuation de la luminosité sans autre perturbation.
- Montage avec RX 2,4Ghz le tout alimenté par SBEC + Filtre sur entrée Multiswitch. Si aucun canal n'est activé, actionner un servo déclenche l'activation de la sortie 3. Si au moins un canal était activé il le reste et il n' y a aucune perturbation du MultiSwitch et on note la même légère fluctuation de l'intensité lumineuse des Leds témoins que dans les autres cas.

Marcel
---------------
avatar
rookie78

Age : 69

http://www.tournereau.com/modelisme/Accueil/Accueil.html

Revenir en haut Aller en bas

Re: Au secours! Multiswitch et SBEC

Message par fabco le Sam 6 Déc 2014 - 16:13

Concernant le branchement du multi-switch vers le récepteur.Je pense que tu as 2 cordons type servo avec (3fils dont signal, v+ , masse).Le filtre que tu as ajouté doit être mis sur un des fils v+ et la masse).L'autre fil v+ provenant de l'autre connecteur ne doit pas servir et donc ne pas être connecté au multi-switch.Idem d'ailleurs avec le fil de masse celui-ci étant commun dans le récepteur.

Le groupe de 3 fils torsadés va directement au récepteur.
c'est bien cela ?
avatar
fabco

Age : 63

Revenir en haut Aller en bas

Re: Au secours! Multiswitch et SBEC

Message par rookie78 le Sam 6 Déc 2014 - 16:28

Oui sur tes recommandations, une seule des deux entrées V+/Masse est connectée sur le Multiswitch.

Non pour la deuxième question: Seuls les fils de signal vont directement au récepteur. V+ et masse sont piqués directement à la sortie du SBEC exactement comme sur le schéma que tu m'as envoyé (voir page 8). Les alimentations des servos sont d'ailleurs réalisées de la même manière. Donc les alims du Rx, du Multiswitch et des servos sont toutes piquées en // à la sortie du SBEC.
Evite de faire passer des courants importants par les fiches d'entrée du récepteur.
Marcel.
--------------
avatar
rookie78

Age : 69

http://www.tournereau.com/modelisme/Accueil/Accueil.html

Revenir en haut Aller en bas

Re: Au secours! Multiswitch et SBEC

Message par fabco le Sam 6 Déc 2014 - 16:38

je n'ai pas trouvé la consommation de ce servo mais j'ai l'impression qu'il n'est pas négligeable.

J'ai l'impression qu'on est confronté avec 2 problèmes.
1 - la puissance du sbec
2 - la fréquence 2.4 qui génère sur le sbec des signaux parasistes

aurais-tu sous la main un servo moins puissant standard 3.3k et voir comment est perturbé l'ensemble?
avatar
fabco

Age : 63

Revenir en haut Aller en bas

Re: Au secours! Multiswitch et SBEC

Message par fabco le Sam 6 Déc 2014 - 16:39

ok pour le câblage
avatar
fabco

Age : 63

Revenir en haut Aller en bas

Re: Au secours! Multiswitch et SBEC

Message par rookie78 le Sam 6 Déc 2014 - 17:35

fabco a écrit:je n'ai pas trouvé la consommation de ce servo mais j'ai l'impression qu'il n'est pas négligeable.
aurais-tu sous la main un servo moins puissant standard 3.3k et voir comment est perturbé l'ensemble?

Oui, les servos du capot du garage. Petis servos taille midi. De mémoire 2,5kgs. Même comportement qu'avec le "gros": Légère baisse de luminosité des LEDS dans les montages qui marchent, et même symptôme dans le montage avec filtre...

Marcel.
-------------------
avatar
rookie78

Age : 69

http://www.tournereau.com/modelisme/Accueil/Accueil.html

Revenir en haut Aller en bas

Re: Au secours! Multiswitch et SBEC

Message par jolibob le Sam 6 Déc 2014 - 17:39

Pour moi la conclusion est simple : le BEC a un souci qui met la chienlit partout.
avatar
jolibob

Age : 67

Revenir en haut Aller en bas

Re: Au secours! Multiswitch et SBEC

Message par patdxfr le Sam 6 Déc 2014 - 17:40

GAZOU a écrit:Salut

je vais sans doute dire une connerie mais au diable l'avarice. J'ai eu un montage qui n'a rien à voir avec votre sujet mais...........
il était conseillé de toujours laisser une led en fonctionnement  entre quoi et quoi ?........pour que l'ensemble stabilise la sortie à 5volts pour éviter un sursaut de voltage . C'était je crois sur une alimentation d'ordinateur bricoléé pour faire une alimentation stabilisée 12v/5v en partant du 220v

Ca va vous faire rigoler mes explications mais va savoir .
On a rit et tout compris étonnant

C'est quand on prend une alim d'ordi (ATX) pour en faire une alim stabilisée 12V, il faut charger le 5V pour que le 12V débite correctement ...

pat_2b
avatar
patdxfr

Age : 55

Revenir en haut Aller en bas

Re: Au secours! Multiswitch et SBEC

Message par Lagaffe le Sam 6 Déc 2014 - 18:08

rookie78 a écrit:
Lagaffe a écrit:Un problème d''alimentation ne m'étonnerait pas, en plus du reste.
Et ce n'est pas un condensateur qui va éliminer la chute de tension provoquée par le démarrage d'un servo (avec un courant de plusieurs Ampères)
Mouais... Sauf que si je monte un Rx en 42Mhz et alimente le tout avec le SBEC tout marche nickel et je peux activer autant de servos que je veux sans avoir d'interférences... Vicieux je vous dis...
Marcel.
---------------
Légère baisse de luminosité des LEDS dans les montages qui marchent, -

Tu devrais relire les réponses, j'ai parlé d'amplitude de signal. C'est la seule chose qui change entre le 41 et le 2,4. Donc...
Et la baisse de luminosité des LED est le signe d'une mauvaise alimentation.
Déjà résoudre ces deux problèmes avec les solutions proposées.
avatar
Lagaffe

Age : 70

Revenir en haut Aller en bas

Re: Au secours! Multiswitch et SBEC

Message par claudius le Sam 6 Déc 2014 - 18:27

Salut

La solution s'approche semble-t-il. Rookie78 tu as câblé juste le fil du signal entre le rx et le module ?
Si c'est le cas je pense que rajouter un fil de masse torsadé avec le fil du signal devrait immuniser au bruit un peu plus la liaison. A faire pour les 2 canaux et aussi déplacer C3 pour la souder sur les pattes d'alimentation du µC.
C'est vrai aussi que l'oscillateur RC sur le µC comme horloge c'est vraiment pas terrible.

Claudius

claudius

Age : 63

Revenir en haut Aller en bas

Re: Au secours! Multiswitch et SBEC

Message par rookie78 le Sam 6 Déc 2014 - 18:42

Lagaffe a écrit:
rookie78 a écrit:
Lagaffe a écrit:Un problème d''alimentation ne m'étonnerait pas, en plus du reste.
Et ce n'est pas un condensateur qui va éliminer la chute de tension provoquée par le démarrage d'un servo (avec un courant de plusieurs Ampères)
Mouais... Sauf que si je monte un Rx en 42Mhz et alimente le tout avec le SBEC tout marche nickel et je peux activer autant de servos que je veux sans avoir d'interférences... Vicieux je vous dis...
Marcel.
---------------
Légère baisse de luminosité des LEDS dans les montages qui marchent, -

Tu devrais relire les réponses, j'ai parlé d'amplitude de signal. C'est la seule chose qui change entre le 41 et le 2,4. Donc...
Et la baisse de luminosité des LED est le signe d'une mauvaise alimentation.
Déjà résoudre ces deux problèmes avec les solutions proposées.

J' ai bien relu, mais dans ton message particulier cité ci-dessus tu parlais de problème d'alimentation... D'où ma réponse...

L'amplitude du signal je n'y crois pas vraiment car comment expliquer que tout fonctionne lorsque l'alim est un accus... Accus ou SBEC, ça ne change pas l'amplitude du signal 2,4 où alors là je ne comprend plus rien (déjà que j'y comprends pas grand chose...).

La mauvaise alim traduite par la luminosité des LEDS "témoin" je ne sais pas comment vraiment l'interpréter et d'ailleurs je la sur-interprète peut-être... D'abord elle est vraiment minime, faut regarder de près dans la pénombre. Puis, elle est présente dans tous les cas qui fonctionnent, avec accus ou SBEC en 42 aussi bien qu'en 2,4. L' alim de tous les composants est en directe depuis Accus ou SBEC pour limiter les pertes à travers des bornes du récepteur. Les câbles sont de bonnes dimensions et la longueur max autour de 20/25cm. Alors améliorer, oui mais quoi...

Marcel.
---------------------

Marcel.
avatar
rookie78

Age : 69

http://www.tournereau.com/modelisme/Accueil/Accueil.html

Revenir en haut Aller en bas

Re: Au secours! Multiswitch et SBEC

Message par Lagaffe le Sam 6 Déc 2014 - 18:47

Comme je disais, quand on travaille à la limite du 1 et du 0 logique on s'expose à des problèmes.
Il n'est pas exclu que le BEC soit en cause, aérien ou filaire.
Si tout fonctionne correctement avec une batterie change de BEC.
Tu parles de câbles de 25 cm maxi. BEC trop près du module ?
avatar
Lagaffe

Age : 70

Revenir en haut Aller en bas

Re: Au secours! Multiswitch et SBEC

Message par rookie78 le Dim 7 Déc 2014 - 10:35

fabco a écrit:intéressante la doc du controleur.
Il y a pas mal de recommandations
comme celle-ci
Votre U-BEC PROTRONIK est conçu pour faire face aux appels de courants que génèrent les servos durant un vol. Ainsi, un
bref appel de courant dépassant de 20 % la valeur nominale ne déclenche pas le système IFR

Votre U-BEC PROTRONIK repose sur le principe du découpage à haute fréquence. Bien que toutes les précautions soient
prises afin que ce module rayonne le plus faiblement possible, nous vous conseillons de placer votre U-BEC le plus loin possible du
récepteur et de son antenne. Nous vous rappelons qu’un test de portée doit être réalisé de façon impérative et systématique avant chaque vol.

des fils sont même torsadés en guise de blindage

il a l'air d'être sensible ce petit bijou de technologie

- Le système IFR est juste une protection contre la surchauffe du BEC en cas de court-circuit ou d' ampérage trop important, c'est à dire avec ce modèle au delà de 4A + 20% soit pratiquement 5A et ce de manière permanente. N'entre sûrement pas en jeu dans notre cas.
- La deuxième remarque c'est juste le principe de précaution et l'ouverture du parapluie juridique... De ce que j'ai pu lire et comprendre, tous les SBEC "rayonnent" plus ou moins... Le 2,4 est d'ailleurs à-priori recommandé en association, étant moins sensible à ces fréquences.
Ce contrôleur /SBEC est principalement utilisé sur les hélicos RC taille 600 ou 700 et a plutôt bonne réputation. Et dans un montage sur hélico, le SBEC n'est jamais bien loin du récepteur...

Marcel.
--------------------
avatar
rookie78

Age : 69

http://www.tournereau.com/modelisme/Accueil/Accueil.html

Revenir en haut Aller en bas

Re: Au secours! Multiswitch et SBEC

Message par rookie78 le Dim 7 Déc 2014 - 16:40

Déjà 10 pages sur ce bazar, où la question de départ était juste d’essayer de voir si je faisais un truc stupide qui pouvait expliquer la panne… Bon de ce côté je suis rassuré, doit y avoir encore quelques neurones qui fonctionnent… Il va être temps de conclure car je pense que toutes les pistes ont été explorées et la réponse du Forum a été fantastique.  génial  génial

J’ ai relu toute la discussion et j’ai essayé d’en faire un résumé. Les différents tests effectués sont présentés dans le tableau suivant :



De plus, l’activation d’un servo provoque une très légère variation de la luminosité des LEDS témoins dans tous les montages qui « marchent », 2,3,4& 6, donc aussi bien avec alimentation par SBEC que par acccus . Sans conséquences pour les montages 2, 3 & 4 et avec une interférence mineure pour 6. Cette variation pourrait correspondre à une très légère chute de tension de l’alim liée à l’appel de courant du servo ou une interférence autre…

- En comparant « 1 » & « 2 », on se dit c’est le 2,4Ghz qui gêne… Mais c’est contredit par « 3 » où 2,4Ghz & Multiswitch font bon ménage…
- En comparant « 1 » & « 3 » on se dit que c’est le SBEC qui sème la pagaille sur le Rx  mais contredit par « 4 » ;  ou sur le Multiswitch mais contredit par « 2 »…
- En comparant « 1 » & « 4 » on se dit c’est le SBEC & le Multiswitch qui ne s’aiment pas… Mais c’est contredit par « 2 »…
- En comparant « 4 » & « 5 » on se dit à nouveau que c’est le couple SBEC & Multiswitch qui coince. Mais toujours contredit par « 2 »…

• En fait il faut avoir la combinaison de deux variables, 2,4ghz + SBEC sur Multiswitch pour coincer, l’ alim du Rx étant indifférente.

• Il semble donc se produire une interaction foireuse entre Rx 2,4 & Multiswitch lors d’une alimentation par le SBEC. Celà semble être confirmé par les effets bénéfiques du filtre proposé par « fabco » (montage « 6 ») et principalement par l’ajout de la diode : Blocage de pics négatifs  ou de retours de signaux parasites provenant du multi-switch vers le récepteur comme l’a expliqué « fabco ».

• L’amplitude et/où la fréquence des signaux en 2,4 ne me semblent pas en cause puisque tout fonctionne lors d’une alim générale par accus.

J’en conclu qu’un concept pas très « robuste » et ancien du Multiswitch doit être la source de tous ces soucis lorsqu’on l’ utilise avec des choses plus « modernes », numériques (2,4 & SBEC) : Horloge interne ou pas, filtrage, détection des niveaux logiques, génération & retour de parasites vers le Rx, je ne suis pas assez qualifié pour faire le tri… Théorie confortée par l’expérience de « Lagaffe » qui résout le problème via des coupleurs optiques. Je remarque aussi que dans le schéma modifié (modernisé) du Multiswitch soumis par « jando », non seulement le processeur, mais aussi son programme ont été changés et  plusieurs résistances ont été ajoutées sur les entrées des signaux ainsi que des capas de ci de là… C‘est aussi en gros ce que me propose « jolibob » (Merci pour l’ offre!) en flashant avec un nouveau programme de son fait un processeur plus récent.

• Les solutions suggérées  et qui s’offrent à moi:
- Le plus simple : Eliminer le problème en ajoutant un accus pour alimenter le Multiswitch. Quand même dommage avec la puissance installée de devoir rajouter un accus. Côté encombrement je suis plutôt juste ! Côté poids ça devient limite… Solution pas facile à réaliser sur ce bateau.
- Utiliser le Multi-switch avec le filtre « fabco » qui résoud 95% des problèmes. Le seul mode d’ échec est l’activation sauvage du canal 3 lors de l’utilisation d’un servo et sans blocage du Multiswitch. Comme je n’utilise que 6 sorties ça pourrait aller. Mais garder un élément quand même un peu foireux dans le montage ne me paraît pas très sain…
- Utiliser des coupleurs optiques comme le suggère « Lagaffe » et éventuellement des convertisseurs de niveau sur les entrées du Multiswitch, convertsisseurs que « patrik82 » me propose gentiment de me réaliser.  Solution lourde pour un objectif quand même des plus simples : Allumer des Leds…
- Refaire une carte « Multiswitch » moderne : Nouveau processeur, nouveau programme, amélioration générale pour la protection des entrées & sorties de la carte, etc… Puis la tester avec divers radios, divers SBEC, etc… pour s’assurer que l’on a un montage fiable et robuste. Projet complet et d’une certaine ampleur. A réserver à un électronicien/programmeur qui souhaite relever le challenge.
- Abandonner le Multiswitch et utiliser autre chose. C'est sans doute ce que je vais faire...

•  Les modules CTI PS4u & PS4o commercialisés par TechniModel me paraissent bien.
. 4 sorties par module.
. Activation par impusion sur un manche d’une demi-course à droite ou à gauche.
. Canal activé/désactivé selon le nombre d’impulsions envoyées (1 pour canal 1, 2 pour canal 2, etc…).
. La sélection de chaque canal est directe (on ne « cycle » pas pour en atteindre un en particulier).
. Comparaison avec le Multiswitch : Du côté des avantages, en combinant deux modules, on a 8 voies sur un seul manche versus 7 voies sur deux manches. Récupérer un manche est très intéressant. Du côté des inconvénients, il faut compter les coups de manche… Bon, je commande seulement des Leds et si je me trompe ce n’est pas fatal… Et à priori je dois pouvoir compter jusqu’à 4… Coût 40€ pour 2 modules CTI versus 27€ pour un Multiswich chez Conrad.
J’ ai reçu deux modules. Les premiers tests rapides sont bons. La sélection des canaux « robuste » (délai entre coups de manches et durée de l’impulsion pas trop critiques) et tout semble fonctionner sans interférences en 2,4, & alimentation générale par SBEC.
Reste à faire un montage propre in-situ et confirmer…

Merci encore à tous les participants à cette discussion et pour les généreuses offres de fourniture de composants et de montage.  salamalec  salamalec

Marcel.
-------------------------
avatar
rookie78

Age : 69

http://www.tournereau.com/modelisme/Accueil/Accueil.html

Revenir en haut Aller en bas

Re: Au secours! Multiswitch et SBEC

Message par rookie78 le Mer 10 Déc 2014 - 18:03

Salut

"jolibob", étant du genre "à ne pas laisser" tomber un problème, est venu me rendre visite avec un nouveau processeur 16F54 programmé par lui.
Nous avons d'abord refait les tests avec le proc d'origine pour s'assurer que je ne faisais rien de stupide, avec les mêmes constatations bizarroïdes.

Puis installation du nouveau proc... Impossible d'initialiser... Ni avec une alim accus ni avec le SBEC...???  bizarre  bizarre

Il décida alors d'examiner le circuit à la loupe et de le comparer au schéma d'origine. Donc démontage de la carte et inspection:
- Première constatation d'un oeil expert: Carte sûrement pas "neuve" mais plutôt re-conditionnée, avec des traces de réparations!! Merci Conrad... nul
- Deuxième constatation: Un pont avait été ajouté entre les entrées des deux signaux sur le proc. peur peur peur peur

Ca explique déjà pourquoi même en ne branchant qu'une voie je pouvais initialiser le bouzin et commander deux sorties...
Aucune raison de garder ce pont... Un coup de fer a souder et hop!

Sans ce pont trouble-fête, le nouveau proc s'initialise et fonctionne (plus rapide et mieux foutu dans les commandes d'ailleurs) mais il reste la même interférence lorsque l'on active un servo...
N 'ayant plus d'idée, nous arrêtons là les manip....

Ce matin, me préparant à remplacer le multiswitch par deux modules CTI, j' enlève le filtre (capa+diode) qui avait été installé sur l'entrée du Multiswitch. Et histoire de ne pas avoir de remords, je re-teste le multi "réparé", avec le nouveau proc et sans filtre... Et là miracle, tout fonctionne parfaitement, en 2,4 et avec SBEC... Plus d'interférence des servos.
Je remplace le 16F54 per le proc d'origine... ET là aussi tout fonctionne nickel...

Alors, alors... Comme d'habitude quand rien n'est logique, c'est qu'il y a un loup... un truc stupide. Ce pont sur les entrées était la source de tous nos ennuis... Pas pris en compte le bon truc, partis sur une fausse piste, nous avions réglé un problème (initialisation) en montant un filtre et en avions créé un autre avec les servos... On avait effectivement une boucle, pas par les masses mais via les voies des signaux.

Bon, je ne m'explique toujours pas pourquoi ça fonctionnait en 42mhz ou en alimentant le Multi avec un accus, je laisse ça aux experts... Mais le principal c'est que ça marche et que tout est rentré dans l'ordre...

Je ne peux que m'excuser platement d'avoir fait bosser nos experts sur de mauvaises données... Le pont n'était pas au programme. Quand je disais que c'était vicieux et stupide...
Merci mille fois à "jolibob" et tous ceux qui ont contribué.

Problème résolu (même si j'ai pas tout compris).
Et un Multiswitch bien câblé "marche" avec un Rx 2,4Ghz et SBEC ... Ouf!
Marcel.
------------------
avatar
rookie78

Age : 69

http://www.tournereau.com/modelisme/Accueil/Accueil.html

Revenir en haut Aller en bas

Re: Au secours! Multiswitch et SBEC

Message par claudius le Jeu 11 Déc 2014 - 15:31

Salut

Bien content pour toi Rocky78 que tes problèmes soient résolus, bravo à Jolibob.
Bon maintenant tu nous donnes un nouvel os à ronger, pourquoi cette co...rie de cablage fonctionnait quand même en 42MHz ... dejadehors

Claudius

claudius

Age : 63

Revenir en haut Aller en bas

Re: Au secours! Multiswitch et SBEC

Message par fabco le Jeu 11 Déc 2014 - 15:34

ceux-ci est une bonne question scratch
avatar
fabco

Age : 63

Revenir en haut Aller en bas

Re: Au secours! Multiswitch et SBEC

Message par jolibob le Jeu 11 Déc 2014 - 17:46

Bonjour à tous,


Comme me le disait Rookie78 en MP : " On ne saura sans doute jamais, faudrait passer pas mal de temps à analyser tout ça et je pense que ça n'en vaut pas la peine"


Néanmoins, je pense que ce n'est pas un problème de fréquence mais de technologie utilisée : il est rare de trouver des µC dans les récepteurs 41MHz alors qu'en 2,4G c'est pratiquement obligatoire. Le problème vient du fait que les signaux arrivant sur les deux voies étaient mélangés par la présence du pont de soudure. Du fait de la chronologie des signaux dans la trame reçue, il ne peuvent jamais arriver en même temps sur les deux canaux. A cause du pont, le signal d'une voie était automatiquement réinjecté sur l'autre voie causant des comportements inattendus du programme inclus dans le récepteur ...


Cordialement
avatar
jolibob

Age : 67

Revenir en haut Aller en bas

Re: Au secours! Multiswitch et SBEC

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Page 6 sur 6 Précédent  1, 2, 3, 4, 5, 6

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum